Total Posts:14|Showing Posts:1-14
Jump to topic:

Speed back to... Poor (post hardware update)

TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/1/2015 2:42:00 PM
Posted: 1 year ago
Right after the hardware upgrade, the general speed on the site seemed to have improved. After some time, it had slowed down again. It seems now that it is at the same level or worse.

I notice terrible lag in the polls most of all. Just entering polls from the front page can take 30+ sec. Posting a reply can sit long enough that the user is sure its not working. 15-20sec? Outside 30+. Forums had the best improvement gain after the upgrade. Now, I see about the same response.

This was a lateral move.
TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/1/2015 2:51:23 PM
Posted: 1 year ago
Notice my double post? Reflection of the problem with lag. There just isnt enough load on this site for this sort of performance penalty.
16kadams
Posts: 10,497
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 12:35:29 AM
Posted: 1 year ago
At 8/1/2015 2:51:23 PM, TBR wrote:
Notice my double post? Reflection of the problem with lag. There just isnt enough load on this site for this sort of performance penalty.

I didn't see a double post, lol
https://www.youtube.com...
https://rekonomics.wordpress.com...
"A trend is a trend, but the question is, will it bend? Will it alter its course through some unforeseen force and come to a premature end?" -- Alec Cairncross
TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 12:42:51 AM
Posted: 1 year ago
At 8/2/2015 12:35:29 AM, 16kadams wrote:
At 8/1/2015 2:51:23 PM, TBR wrote:
Notice my double post? Reflection of the problem with lag. There just isnt enough load on this site for this sort of performance penalty.

I didn't see a double post, lol

Look at the forum at the same time as the original. Its there.

Look, the problems are not huge, the biggest problem is perception. The perception is that no one cares one bit. True or not, that is what people think, and regardless of progress on any one issue, they will remain behind the expectation curve until they address communications better.
Hayd
Posts: 4,022
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 1:52:13 AM
Posted: 1 year ago
At 8/1/2015 2:42:00 PM, TBR wrote:
Right after the hardware upgrade, the general speed on the site seemed to have improved. After some time, it had slowed down again. It seems now that it is at the same level or worse.

I notice terrible lag in the polls most of all. Just entering polls from the front page can take 30+ sec. Posting a reply can sit long enough that the user is sure its not working. 15-20sec? Outside 30+. Forums had the best improvement gain after the upgrade. Now, I see about the same response.

This was a lateral move.

I agree, I have noticed every once in a while the page will not load, same symptoms. Its a shame.
TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 1:54:20 AM
Posted: 1 year ago
See... Hardware can go a long long way to fixing problems. The thing is, just adding hardware has never been a proper fix.
bsh1
Posts: 27,504
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 1:56:04 AM
Posted: 1 year ago
My font's also been messed up post-update.
Live Long and Prosper

I'm a Bish.


"Twilight isn't just about obtuse metaphors between cannibalism and premarital sex, it also teaches us the futility of hope." - Raisor

"[Bsh1] is the Guinan of DDO." - ButterCatX

Follow the DDOlympics
: http://www.debate.org...

Open Debate Topics Project: http://www.debate.org...
TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 4:07:29 PM
Posted: 1 year ago
At 8/2/2015 1:56:04 AM, bsh1 wrote:
My font's also been messed up post-update.

Why I can't seem to get a majority behind the idea of bug tracking is inexplicable to me. It is next to impossible to manage any bit of software (or site) without a little organization, and the site is lacking that.

I can look on the forums almost any day finding a complaint, and the killer of it is, the perception from the users is a MUCH LARGER problem than the issue that is reported.
TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 4:15:16 PM
Posted: 1 year ago
Just for kicks, lets look at the jquery core bugs

https://github.com...

my point is, issues happen all the time. There are few that mock something like jQuery, but issues big and small happen every day! Addressing them keeps the user base happy. Inactivity.

Now, a look at google apps script
https://code.google.com...

As big as Google is, as good as they are, and with proper tracking, when you read through the comments you WILL find angry responses. Why? No communication.

I am SURE there are more people developing with jquery then using the app script engine from Google.

Well.... Let me try to bring this back on center. DDO needs a simple and proper bug tracking procedure, and just a touch of communication with the support staff to improve the perception problem.
TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 4:25:49 PM
Posted: 1 year ago
And another thing!!!!

OK. The thing is, without going to great extremes, we could go a long way by just adding one forum for bugs. A single "bug thread" is next to worthless. I outlined a concept for this elsewhere that got mixed reviews.

Know what.... Since I was thinking of Google App Script, I may just do something with it. I think I could build a serviceable bug tracker with it in a day or two...
imabench
Posts: 21,229
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 7:22:04 PM
Posted: 1 year ago
At 8/2/2015 1:56:04 AM, bsh1 wrote:
My font's also been messed up post-update.

my penis aims slightly to the left to! DAMN YOU JUGGLE!!!!
Kevin24018 : "He's just so mean it makes me want to ball up my fists and stamp on the ground"
Geogeer: "Nobody is dumb enough to become my protege."

7/14/16 = The Presidency Dies

DDO: THE MOVIE = http://www.debate.org...
http://www.debate.org...

VP of DDO from Dec 14th 2014 to Jan 1st 2015
TBR
Posts: 9,991
Add as Friend
Challenge to a Debate
Send a Message
8/2/2015 7:27:45 PM
Posted: 1 year ago
At 8/2/2015 7:22:04 PM, imabench wrote:
At 8/2/2015 1:56:04 AM, bsh1 wrote:
My font's also been messed up post-update.

my penis aims slightly to the left to! DAMN YOU JUGGLE!!!!

This is not about blaming the site owners, it is trying to HELP the owners.

There is nothing more frustrating than to have problems that go unreported. Some time, when the users are frustrated, you will hear "well, that has been messed up for a YEAR" and you wonder 1) is that true? 2) Why didn't I know?

I have no expectation of the owners to spend any time USING the site, so the only proper way to make issues apparent is to report them in a logical and organized way
medv4380
Posts: 200
Add as Friend
Challenge to a Debate
Send a Message
8/3/2015 8:49:40 PM
Posted: 1 year ago
At 8/2/2015 7:27:45 PM, TBR wrote:
There is nothing more frustrating than to have problems that go unreported. Some time, when the users are frustrated, you will hear "well, that has been messed up for a YEAR" and you wonder 1) is that true? 2) Why didn't I know?

If the front page is any indication I'd say the issue is probably with the database for the site, and a bad time entry. The front page is currently looping the same debates that have long since past their voting periods. However, the time keeps looping over a hour back to 0 and then to negative values. I assume the negative is because my system time is correct and it knows that the date is in the past.

A mangled index that was intended on speeding up the site could cause this. There have been a number of date related problems recently. I mostly assumed it was due to the large amount of necro posting that was hammering the servers causing the error 500 to come up. Nothing worse than a forum fight to take out a server, except cats. Cats are always worse.